193 Lotus blogs updated hourly. Who will post next? Home | Blogs | Search | About 
 
Latest 7 Posts
Sametime file transfer not working due to chat logging settings
Thu, Apr 27th 2017 147
Orient Me and mongoDB connection failures
Thu, Apr 20th 2017 77
Orient Me and some things I’ve come across and wrestled with
Thu, Apr 13th 2017 11
Version of Notes Java breaks IBM Connections Files plugin when TLSv1.2 is enforced
Wed, Mar 29th 2017 10
Connections Pink and container orchestration using CfC
Thu, Mar 16th 2017 9
Whiteboard now removed from Sametime meetings
Tue, Mar 14th 2017 5
Exception when Connections email digests are sent – LO90678
Thu, Mar 9th 2017 7
Top 10
Sametime file transfer not working due to chat logging settings
Thu, Apr 27th 2017 147
Orient Me and mongoDB connection failures
Thu, Apr 20th 2017 77
LDAP error code 49 – Failed, invalid credentials – user cannot log in to Connections
Thu, Jan 8th 2015 18
Solution for Sametime connection issue with iNotes when SSL is used
Thu, Jun 26th 2014 11
Orient Me and some things I’ve come across and wrestled with
Thu, Apr 13th 2017 11
Version of Notes Java breaks IBM Connections Files plugin when TLSv1.2 is enforced
Wed, Mar 29th 2017 10
The importance of Java and Cognos with IBM Connections
Tue, Mar 25th 2014 9
HOMEPAGE.SR_RESUME_TOKENS duplicate data in IBM Connections
Sat, Nov 19th 2016 9
Connections Pink and container orchestration using CfC
Thu, Mar 16th 2017 9
IBM Sametime Video Manager start up scripts
Fri, Apr 22nd 2016 8


Sametime 9 policies not working due to slashes in the policy name in SSC
Twitter Google+ Facebook LinkedIn Addthis Email Gmail Flipboard Reddit Tumblr WhatsApp StumbleUpon Yammer Evernote Delicious
collaborationben    

I had come back on site to a customer to deploy some other Sametime 9 services and found that the managed-settings.xml wasn’t being applied to the clients.

I remembered reading Gabriella Davis’ blog http://turtleblog.info/2014/04/02/problems-deploying-sametime-policies-the-missing-link so I found it and at first I enabled POLICY_DEBUG_LEVEL=5 and then updated console.properties adding  SSCUserName, SSCPassword and removing SSCEncodedAuthorization.

I added the following trace to STConsoleServer, *=info:com.ibm.sametime.console.admin.plugins.policy.*=all which allowed me to see the policies read from the STSC.POLICY.TEMPLATE table to make sure they were populated.

The Community server was restarted that evening but still policies were not being applied to the clients. Thanks to the debug I then had some useful output in the Trace directory to look through and found this:

[ 07:58:57.560 | 04.12.2014 | FINEST | 1 ] : DbXmlBlackBox : readSortedData : Policy DTO=> Policy ID: Managed.settings.28/10/14;Policy Weight: 3;Policy Label: null;Policy Type: USER
[ 07:58:57.576 | 04.12.2014 | SEVERE | 1 ] : DbXmlBlackBox : readSortedDataForProducts : PolicyException:
com.ibm.sametime.policy.types.PolicyException: com.ibm.sametime.console.admin.services.exception.ServiceException: com.ibm.sametime.console.common.http.api.exception.HttpBadRequestException: Not Found
Caused by: com.ibm.sametime.console.admin.services.exception.ServiceException: com.ibm.sametime.console.common.http.api.exception.HttpBadRequestException: Not Found

I previously created an IM policy called “Managed settings 28/10/14″ which wasn’t liked. As there is xml involved I removed the slashes to leave “Managed settings 281014.”

I restarted STConsoleServer and then restarted the STPolicy Windows service on the Community server and this triggers activity on the STConsoleServer. Now that the slashes were removed the files policies.server.xml was updated adding the managed settings policy to policies.user.xml which is in the program directory of the Community server. Subsequently, the policy was then applied to the clients.

http://ssc:9080/stpolicy/policy/all

This provide high level information on all policies, IM, audio/video etc.

http://ssc:9080/stpolicy/policy/av.anonymous.policy & http://ssc:9080/stpolicy/policy/av.default.policy

These URLs provide details of the default audio/video policies.




---------------------
http://collaborationben.com/2014/12/05/sametime-9-policies-not-working-due-to-slashes-in-the-policy-name-in-ssc/
Dec 05, 2014
7 hits



Recent Blog Posts
147
Sametime file transfer not working due to chat logging settings
Thu, Apr 27th 2017 7:11a   Ben Williams
A
77
Orient Me and mongoDB connection failures
Thu, Apr 20th 2017 3:16p   Ben Williams
A
11
Orient Me and some things I’ve come across and wrestled with
Thu, Apr 13th 2017 7:04p   Ben Williams
A
10
Version of Notes Java breaks IBM Connections Files plugin when TLSv1.2 is enforced
Wed, Mar 29th 2017 2:39p   Ben Williams
A
9
Connections Pink and container orchestration using CfC
Thu, Mar 16th 2017 9:16a   Ben Williams
A
5
Whiteboard now removed from Sametime meetings
Tue, Mar 14th 2017 9:30p   Ben Williams
A
7
Exception when Connections email digests are sent – LO90678
Thu, Mar 9th 2017 10:03a   Ben Williams
A
7
iOS push notifications not received due to expired APNs certificates
Wed, Mar 8th 2017 5:45p   Ben Williams
A
5
Configure Connections to use SMTP MX records to multiple servers
Wed, Feb 22nd 2017 6:43p   Ben Williams
A
6
IBM Connections Mail not working due to Domino view oddness
Fri, Jan 6th 2017 9:31p   Ben Williams
A




Created and Maintained by Yancy Lent - About - Planet Lotus Blog - Advertising - Mobile Edition