199 Lotus blogs updated hourly. Who will post next? Home | Blogs | Search | About 
 
Latest 7 Posts
How do I avoid deletion of plan branch in Bamboo?
Thu, Jul 27th 2017 4
Orika mapper...
Wed, Jul 26th 2017 5
Do you miss "Expressions" view while debugging in Eclipse?
Sun, Jun 25th 2017 3
View by projects or working sets in Eclipse
Tue, May 23rd 2017 4
Hybris setup issue: Unsupported major.minor version 52.0
Thu, Mar 23rd 2017 1
If you can't install Oracle Express XE 11g 2 on Windows...
Wed, Mar 22nd 2017 5
How could I be so stupid using hibernate criteria with timestamp?
Wed, Aug 31st 2016 3
Top 10
SECJ0118E with form authentication and spnego enabled
Mon, Jan 6th 2014 8
Back to basics
Tue, Jun 7th 2016 7
WASService.sh and ulimit.... a tricky combo
Thu, Nov 14th 2013 6
Beethoven a Latina
Fri, Sep 18th 2015 6
How I ran Gradle with cntlm
Wed, May 25th 2016 6
Cognos-setup.bat error
Tue, Nov 12th 2013 5
SVN: E175002: Getting crazy with Maven Release Plugin (solved)
Wed, Sep 23rd 2015 5
Building bitcoin/litecoin on mac os x missing EC.h
Mon, Nov 9th 2015 5
If you can't install Oracle Express XE 11g 2 on Windows...
Wed, Mar 22nd 2017 5
Orika mapper...
Wed, Jul 26th 2017 5


Building bitcoin/litecoin on mac os x missing EC.h
Twitter Google+ Facebook LinkedIn Addthis Email Gmail Flipboard Reddit Tumblr WhatsApp StumbleUpon Yammer Evernote Delicious
   

For my own fun, I was playing around with bitcoin, to check how the parameters of the cryptocurrencies can be modified.

After recent upgrades to my OS, I could not build any longer the bitcoind. Seems like something changed on that side. Now this command

./configure --with-gui=qt5 --enable-debug

Was sistematically producing 

configure: error: OpenSSL ec header missing


EC is the file for elliptic curve cryptography. I had brew correctly configured, and the header files were all correctly present. After some time spent inspecting the issue, on github I was able to find the solution for this problem. I simply add to export the following




export LDFLAGS=-L/usr/local/opt/openssl/lib



export CPPFLAGS=-I/usr/local/opt/openssl/include






There is aksi pull request on bitcoin for that, I hope I could save you some time



https://github.com/bitcoin/bitcoin/pull/6885/files?diff=split&unchanged=expanded




---------------------
http://fdecollibus.blogspot.com/2015/11/building-bitcoinlitecoin-on-mac-os-x.html
Nov 09, 2015
6 hits



Recent Blog Posts
4
How do I avoid deletion of plan branch in Bamboo?
Thu, Jul 27th 2017 4:37p   Francesco De Collibus
Make sure the following checkbox is not flagged:
5
Orika mapper...
Wed, Jul 26th 2017 4:19p   Francesco De Collibus
The Orika mapper used in Hybris always perform a deep copy based on the attribute name instead of the attribute class.
3
Do you miss "Expressions" view while debugging in Eclipse?
Sun, Jun 25th 2017 4:19p   Francesco De Collibus
From time to time, I forget where the expression view can be set in Eclipse... it's right here in the Window panel
4
View by projects or working sets in Eclipse
Tue, May 23rd 2017 12:37p   Francesco De Collibus
View by projects or working sets in Eclipse...always comes in handy!
1
Hybris setup issue: Unsupported major.minor version 52.0
Thu, Mar 23rd 2017 3:49p   Francesco De Collibus
While I was typing the final "ant all" command for hybris, it miserably failed with the following exception hybris/bin/platform/resources/ant/antmacros.xml:123: java.lang.UnsupportedClassVersionError: de/hybris/ant/taskdefs/DbDriverValidator : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) Even though a "java -version" gave me back version 8, ant is still using $JAVA_HOME variable. So you have to change it into the script. My suggestion is that y
5
If you can't install Oracle Express XE 11g 2 on Windows...
Wed, Mar 22nd 2017 10:26p   Francesco De Collibus
I spent the whole afternoon trying to set up a Oracle Express instance without any success. I had the drivers installed, but I could not uninstall them. It looked like the main instance was not correctly set up. After looking around, I noticed that even after complete uninstall of Oracle XE still the ORACLE_HOME environment variable was still there. I tried again manually removing it from System Variables and then reinstalling... and it finally worked!
3
How could I be so stupid using hibernate criteria with timestamp?
Wed, Aug 31st 2016 8:06p   Francesco De Collibus
I needed to make a query to find all records valid today for columns with effectiveFrom and effectiveTo range I spent a couple of hours trying to understand why criteria.add(Restrictions.ge("effectiveFrom",currentDate.getTime())); criteria.add(Restrictions.le("effectiveTo",currentDate.getTime())); was giving no results. After many trials and attempts with other criteria tricks, I remembered that hibernate is not comparting if currentDate.getTime is greater than ef




Created and Maintained by Yancy Lent - About - Planet Lotus Blog - Advertising - Mobile Edition