203 Lotus blogs updated hourly. Who will post next? Home | Blogs | Search | About 
 
Latest 7 Posts
Domino 10 – to be continued!
Mon, Nov 6th 2017 5
IBM Connections 6 – Following and Followers blank
Wed, Oct 25th 2017 5
Exchange integration into WebSphere Portal (SSO – Kerberos)
Tue, Sep 26th 2017 6
User provisioning for IBM Connections Cloud – You have the choice
Mon, Aug 28th 2017 4
SAML & IBM Connections 5.5 – not a dream team
Fri, Aug 18th 2017 7
IBM Docs – Migration from DB2 –> ORACLE
Fri, Jul 7th 2017 2
IBM Connections – trouble adding additional nodes
Wed, May 31st 2017 4
Top 10
DB2 Instance autostart does not work on SLES 12 / RHEL 7
Tue, Jul 12th 2016 17
Configuration of secret key storage in WebSphere Application Server
Thu, Mar 12th 2015 15
SAML – Enterprise SSO in the WebSphere world
Mon, Jul 20th 2015 15
Security Bulletin: HTTP Response Splitting in WebSphere Application Server (CVE-2016-0359)
Tue, Sep 13th 2016 10
IBM Connections: Create external Users / Community using rest API
Wed, Mar 25th 2015 9
HTTP Outbound authentication via SAML
Tue, Oct 6th 2015 9
WebSphere custom TAI – Doing SSO the right way
Tue, Sep 6th 2016 9
IBM Connections Docs – file preview not possible for some CCM pdf files
Thu, Nov 17th 2016 9
Security Bulletin: Vulnerabilities in Apache Struts affects IBM WebSphere Application Server (CVE-2016-1181 and CVE-2016-1182) (2016.06.28)
Tue, Sep 13th 2016 8
IBM Connections vulnerability – fixes for CVE-2014-3004 / CSVV in detail
Tue, Mar 3rd 2015 7


SAML & IBM Connections 5.5 – not a dream team
Twitter Google+ Facebook LinkedIn Addthis Email Gmail Flipboard Reddit Tumblr WhatsApp StumbleUpon Yammer Evernote Delicious
Julius Schwarzweller    

Hi all,

last week we had to fight with an activation of SAML on a IC 5.5 CR3 environment.

The setup was:

  • IBM Connections 5.5 CR3 as test instance
  • ADFS Server 3.0 (I know… it is only tested with ADFS 2.0 – but works with 3.0 too)

We followed the instructions from the IBM Connections Knowledge Center. Smooth setup everything standard procedure. When testing this setup, the redirect to the IdP was initiated. After logging into the IdP the browser was redirected to IBM Connections ACS app. But then a loop started. IdP – Connections – IdP – Connections – IdP …Just until the ADFS Server detected this look and cancelled the request (from the ADFS error log):

 

Encountered error during federation passive request.
Additional Data
Protocol Name:
Saml
Relying Party:
https://connections.server.com/samlsps/acs

Exception details:
Microsoft.IdentityServer.Web.InvalidRequestException: MSIS7042: The same
client browser session has made '6' requests in the last '2' seconds.
Contact your administrator for details.
   at
Microsoft.IdentityServer.Web.Protocols.PassiveProtocolHandler.UpdateLoopDetectionCookie
(WrappedHttpListenerContext context)
   at
Microsoft.IdentityServer.Web.Protocols.Saml.SamlProtocolHandler.SendSignInResponse
(SamlContext context, MSISSignInResponse response)
   at
Microsoft.IdentityServer.Web.PassiveProtocolListener.ProcessProtocolRequest
(ProtocolContext protocolContext, PassiveProtocolHandler protocolHandler)
   at Microsoft.IdentityServer.Web.PassiveProtocolListener.OnGetContext
(WrappedHttpListenerContext context)

Enabling traces on both InfraCluster & UtilsCluster showed us the following error message:

[8/15/17 9:06:59:669 CEST] 000000fb ContextManage 3 Opaque token lookup via mbean will not occur.
[8/15/17 9:06:59:669 CEST] 000000fb ContextManage 3 Exception getting opaque token from originating server.
com.ibm.websphere.security.auth.WSLoginFailedException: SSO token uniqueID not null, but opaque token not found. Need to re-challenge the user to login again.
at com.ibm.ws.security.auth.ContextManagerImpl.getOpaqueTokenFromCacheOrOriginatingServer(ContextManagerImpl.java:1924)
at com.ibm.ws.security.auth.ContextManagerImpl.login(ContextManagerImpl.java:3483)

There is a technote for this describing this issue.

Basically this technote summarizes that this problem is caused by:

“In Websphere Application Server 8.5.5.7 and 8.5.5.8 there are two settings which can contradict each other in certain circumstances if they are both set to true. ”

Addition to this: The properties IBM talks about is also active in WAS 8.5.5.9. From 8.5.5.10 on the property was removed.

The property is called “com.ibm.websphere.security.disableGetTokenFromMBean”

....
com.ibm.websphere.security.disableGetTokenFromMBean
Use this property to disable the outbound SOAP call to retrieve the subject from the originating server when Single Sign-On is enabled. Typically, when Single Sign-On is enabled, and an inbound request needs to be authenticated, the receiving server attempts to retrieve the authentication from the originating server. The connection between the sending and receiving servers never times out during this callback process. When this property is set to true, the receiving server does not attempt to authenticate the inbound request.
.... 

 

And it is set to true by default. This caused the loop.

Setting this to “false” and restarting the cell, SAML authentication immediately started working.

It would be very helpful to get a short link in the IBM Connections 5.5 Knowledge Center to the above technote! This would have saved quite some time.



---------------------
http://techblog.gis-ag.info/2017/08/18/saml-ibm-connections-5-5-not-a-dream-team/
Aug 18, 2017
8 hits



Recent Blog Posts
5
Domino 10 – to be continued!
Mon, Nov 6th 2017 8:48a   GIS Techblog
Welcome to the first post about IBM Domino on our GIS AG Techblog! Here at GIS AG, we have a dedicated IBM Domino team made up of certified specialists for everything from development, to administration, support and beyond. On this blog we will be sharing the latest news and technical information about IBM Domino. If you have any questions or comments, please, feel free to write an Email to: frederik.potyka@gis-ag.com Visit our About Us page! Domino  10 – This year Notes and Domino 9.0
5
IBM Connections 6 – Following and Followers blank
Wed, Oct 25th 2017 8:42a   GIS Techblog
IBM Connections 6 – Following and Followers blank Hi, during the last weeks we had to deal with a strange problem in an IBM Connections 6 environment. The system was migrated from IC 5.5 to IC 6 and live for about 4 weeks when suddenly the following problem occurred: Neither users that I follow nor followers were shown in the UI. Despite installing the latest Fixes no bigger changes have been performed on the system. I was able to follow a user: Looks good: Then opening “Following
6
Exchange integration into WebSphere Portal (SSO – Kerberos)
Tue, Sep 26th 2017 12:03p   GIS Techblog
Exchange integration into WebSphere Portal (SSO – Kerberos) During the last years working with Portal I had several challenges with WebSphere Portals HTTP Outbound Proxy (aka. Ajax Proxy) in terms of authenticating backend calls to various other systems. What we`ve done so far in terms of SSO / backend authentication: – Authenticating using LTPAToken – Authenticating using SAML – Authenticating using SPNEGO / Kerberos (this was a new one for me) The challenge this time
4
User provisioning for IBM Connections Cloud – You have the choice
Mon, Aug 28th 2017 1:42p   GIS Techblog
User provisioning for IBM Connections Cloud – You have the choice Customers who use IBM Cloud for Connections, Sametime or other applications face the problem to manage their cloud accounts. For some single users you can use the Web frontend to add or change user accounts or to assign subscriptions and licenses to users. But in real world scenarios it is not possible to manage thousands of users manually or to keep them synchronized with an on-prem user repository or LDAP. This can be handled
8
SAML & IBM Connections 5.5 – not a dream team
Fri, Aug 18th 2017 7:45a   GIS Techblog
Hi all, last week we had to fight with an activation of SAML on a IC 5.5 CR3 environment. The setup was: IBM Connections 5.5 CR3 as test instance ADFS Server 3.0 (I know… it is only tested with ADFS 2.0 – but works with 3.0 too) We followed the instructions from the IBM Connections Knowledge Center. Smooth setup everything standard procedure. When testing this setup, the redirect to the IdP was initiated. After logging into the IdP the browser was redirected to IBM Connections ACS
2
IBM Docs – Migration from DB2 –> ORACLE
Fri, Jul 7th 2017 9:52a   GIS Techblog
IBM Docs – Migration from DB2 –> ORACLE Hi, within our last big project, we had the challenge to transfer the IBM Docs database from DB2 to ORACLE. Within this database comments and other document related data is stored. Officially there is no script available to perform this move using DBT (remove constraints / transfer / reapply constraints). We looked into the database and figured out how to perform this task using DBT – so we are not dependent on any other products. We m
4
IBM Connections – trouble adding additional nodes
Wed, May 31st 2017 2:52p   GIS Techblog
IBM Connections – trouble adding additional nodes Hi all, we are currently involved in a project where we installed a 1 node IBM Connections 6 Cluster and later added a second node to the cell. So far so good… Everything that needs to be done after adding the second node is described here … Everything? Yes, mainly… but not in the mandatory details as I think! Missing custom properties and other settings might result in non-functional nodes. Especially not setting httpSess
4
SNOUG 2017 Presentation – SikaConnect goes External
Thu, Mar 23rd 2017 1:06p   GIS Techblog
SNOUG 2017 Presentation – SikaConnect goes External Hi all, yesterday I was at SNouG in Zurich. I had a great time there – good speakers and a overall perfectly organized event (would we expect sth. else from Switzerland? ) Raymond Weber from SIKA Informationssysteme AG and I did a session about the SIKA Extranet Feature:
7
Whiteboard in IBM Sametime Meeting 9.0.1 removed
Fri, Mar 17th 2017 10:43a   GIS Techblog
Whiteboard in IBM Sametime Meeting 9.0.1 removed IBM implemented in Sametime Meeting 9.0.1 a whiteboard function as technical preview. Ben described in his articel how to enable this feature: https://collaborationben.com/2016/05/20/whiteboard-in-sametime-9-0-1/ With the current cumulative Fix 901-ST-General-FP-SMOL-AK4G43  for the Meeting Server IBM has removed this function. The response on my PMR was: “I can confirm The Meetings Whiteboard feature release is being put on hold indefinitely.
6
Wikis content not accessible…
Thu, Jan 26th 2017 10:54a   GIS Techblog
Wikis content not accessible… Hi, it`s been quite a long time; many projects at the moment so that blogging needs to wait Last week we had a very interesting problem at one customer’s environment. When accessing a Wiki, the page was displayed blank – no content was available. Browsing to older versions of this wikis worked. The error in the log: Parsing error… Wikis content (the body) gets store in the filesystem as xml files. If you access a Wiki there is a XML parser




Created and Maintained by Yancy Lent - About - Planet Lotus Blog - Advertising - Mobile Edition