264 Lotus blogs updated hourly. Who will post next? Home | Blogs | Search | About 
 
Latest 7 Posts
IBM Connections - Forum Fun - Reply impossible - solved
Mon, Apr 27th 2015 18
IBM Connections - Following communities per default
Mon, Mar 30th 2015 7
IBM connections - Adding 1000 Users to a community
Fri, Jan 16th 2015 8
IBM Connections - Community Login empty
Fri, Jan 16th 2015 9
IBM Connections Remove lots of users from all Communities
Fri, Jan 16th 2015 8
IBM Connections - Photo Preview not working
Thu, Jan 15th 2015 5
Resetting the E-Mail Notification Settings for all users
Thu, Jan 8th 2015 8
Top 10
IBM Connections - Forum Fun - Reply impossible - solved
Mon, Apr 27th 2015 18
XPages Mobile with offline Data - Caveat
Thu, Apr 17th 2014 13
Centos 7 - VM Ware Player
Sat, Aug 2nd 2014 13
IBM Connections - File Viewer 1.0.6 - Journey to Mime
Mon, Dec 15th 2014 12
$$Previous can be tricky with iFrames
Thu, May 8th 2014 11
IBM Connections Activity Stream - Stopped working
Fri, Dec 19th 2014 11
IBM Connections - Community Login empty
Fri, Jan 16th 2015 9
Resetting the E-Mail Notification Settings for all users
Thu, Jan 8th 2015 8
IBM Connections Remove lots of users from all Communities
Fri, Jan 16th 2015 8
IBM connections - Adding 1000 Users to a community
Fri, Jan 16th 2015 8




Recent Blog Posts
18
IBM Connections - Forum Fun - Reply impossible - solved
Mon, Apr 27th 2015 8:10a   Urs Meli
We had a small Issue with a connections forum entries. Suddenly editing or replying was no longer possible and in another case the topic would not open at all. Further investigation on the server logs revealed an error with a certain member id and a node id (= forum entry id). Going to Forum.DF_Node and Forum.DF_Contentref tables in the connections db, I was able to extract the bodies of topic and its replies. Analysis of the body revealed a strange @Mention structure. I corrected it an
7
IBM Connections - Following communities per default
Mon, Mar 30th 2015 12:50p   Urs Meli
The customer wants that every member should follow their community per default with the possibility to opt-out. The solution I found was this from urspringer.de which was not a good option for me as I personally dislike database triggers. The solution I'm gonna implement is really easy based on a database and TDI/SDI. As I am Notes developer and the customer has Domino already up and running, I did a small database with simple form which basically holds the community_uuid, member_uuid
8
IBM connections - Adding 1000 Users to a community
Fri, Jan 16th 2015 5:36p   Urs Meli
Here is just a small script to import a large number of users to a community. It just requires a text file with an email address on each line. save it in emails.py and call it like wsadmin -f emails.py > log.txt import os from jarray import array execfile("communitiesAdmin.py") filesrc=open('/home/connections/tmp/emails.txt','r') CommunityID="b2e4c442-6bb0-4ddf-b576-c253193fe8d7" lines=0 first=filesrc.readline().strip() emails=[] emails.append(&
9
IBM Connections - Community Login empty
Fri, Jan 16th 2015 5:09p   Urs Meli
The Login page from communities suddenly showed no content. [Servername]/communities/login returned nothing. With Firebug I received a answer with http status 200 which was empty. Once logged in through the homepage, the communities worked. So the customized login.jsp did work Seems that at some point the cached customized login.jsp become corrupt. As soon as I changed something in the login.jsp and saved it again. Everything worked again. Maybe cleaning up the websphere temp folder might
8
IBM Connections Remove lots of users from all Communities
Fri, Jan 16th 2015 3:13p   Urs Meli
If you want to remove the communities access from a lot of people and you have a file with an email address on each line you could use something like the following script to remove the membership import os from jarray import array execfile("communitiesAdmin.py") filesrc=open('/home/connections/tmp/emails.txt','r') lines=0 first=filesrc.readline().strip() emails=[] emails.append('XX') w
5
IBM Connections - Photo Preview not working
Thu, Jan 15th 2015 1:10p   Urs Meli
We had a strange issue with a newly installed Connections 5 CR1 installation. We were suddenly unable to upload photos to the profile. The preview would just "uploading" and it would run forever. Restarting the profiles app nor the server did help. To prepare for the PMR we already collected the Trace logs and fiddled with Fiddler. The strange thing happend when we turned the trace log off.... The Photo upload worked again...
8
Resetting the E-Mail Notification Settings for all users
Thu, Jan 8th 2015 1:11p   Urs Meli
Configuring the default Email-Notification is well documented inside the Knowledge Center. But if you have to reset all the users to certain settings you could do the following. 1. use your trusted SQL tool (IBM Data Studio , Dbeaver or whatever you like to connect to your DB2) and connect to your Connections DB2 2. Connect to the Homepage DB 3. use the following commands to update the settings First you'll need a user, who already has the desired settings. You could log in with
11
IBM Connections Activity Stream - Stopped working
Fri, Dec 19th 2014 6:11a   Urs Meli
Dealing with Connections can be a pain. We just installed a new Connections environment. Customized it. Tweaked this and that. And all of a sudden the status updates stopped working. Writing a status update in the browser didn't show any errors. The update went to the stream, but it disappeared uppon refresh. The trace.log didnt show any exact failure. I was able to find my status updates in the homepage database, but not in my Homepage. A couple of days later, we had to remove "Admi
12
IBM Connections - File Viewer 1.0.6 - Journey to Mime
Mon, Dec 15th 2014 10:10a   Urs Meli
We encountered a strange issue. We uploaded a thousends of files through the IBM SBT. Upon testing the files in the File Viewer 1.0.6 we saw that *.doc worked but the *.docx wouldn't. Examining the SystemOut on the Viewer Server I found CLFAF402W: Unsupported MIME type Having a quick look at the Files database showed, that all the docx/pptx had either no mime - type or the binary/octet-stream After correcting the mime-type everything worked. Here's the script for corr
13
Centos 7 - VM Ware Player
Sat, Aug 2nd 2014 2:14p   Urs Meli
I tested centos 7 on my vmware player. When I added a second network card, it was not detected from centos. A long journey through the internet began... I tried a lot of things... lspci showed both network cards, but the NetworkManager did not recognize the second NIC. The first card was an Intel, the second a AMD. I found a note that the support for this AMD card in Centos / RHEL 7 is dropped. In the VMWare Player config I could not change the type of nic. I had to edit my .vmx file




Created and Maintained by Yancy Lent - About - Planet Lotus Blog - Advertising - Mobile Edition